Error when uploading

Dec 2, 2010 at 9:43 AM

Hi Serkant!

Thanks for providing this great tool, but unfortunately it's not working for me.

Server: MOSS 2007
Outlook: Tested on 2007 and 2010 32-bit
Client: Windows 7 Professional
All german versions.
Connector version: 2.4.2.3

First I drag&drop an email or an attachment to the hierachy view. Then the upload window pops up. When I then click on "Upload" I get: "An error occured while uploading. Please check the log"

The log looks as following:
DestinationUrl: http://sharepoint/test/E-Mail-Test/xxxxx.pdf
ErrorCode: Unknown
ErrorMessage: Object reference not set to an instance of an object

I tried to change the settings from *.msg to *.doc. I also tried to create a new document library, without success. Then I tried to add the required custom fields to the document library (title, to, from, etc.), also without success.

What can I do? Please let me know, if you need some more details.

Thanks in advance!

Regards,

Andreas


Dec 2, 2010 at 10:09 AM

Hi Serkant!

OK, I think I found the problem. It doesn't like the minus sign - in pathes. I created a new document library "mytest" and now it's working :-)

Regards,

Andreas

Dec 2, 2010 at 10:17 AM
Edited Dec 2, 2010 at 10:18 AM

But now I found another problem:

If the email subject contains a # it's not working, as MOSS is not accepting some special characters in filenames.

According to the error message, the following signs are not allowed:

# % & * : < > ? / { | }

It looks like you are already filtering some of those characters, but maybe not the #

Thanks!

Regards,

Andreas

Coordinator
Dec 3, 2010 at 1:25 AM

Thanks Andreas,

Missing characters are being trimmed now. Try http://spoutlookconnector.codeplex.com/releases/view/56824 please

Dec 6, 2010 at 1:46 PM

Hello Serkant!

Thanks! It's working now :-)

Regards,
Andreas

Feb 23, 2011 at 10:24 AM

Hi Serkant

Thank you as well for this great tool.
I'm having the same problem Graf17 had and receive the same error message (But I use Outlook 2010 and SharePoint 2010 Online).
Unfortunatley all the SiteCollections contain an minus sign in their URL... is it somehow possilbe to make this work regardless that there is a minus sign? 

Thanks in advance & kind regards!
Mishael

Feb 24, 2011 at 8:58 AM
Edited Feb 24, 2011 at 10:18 AM

-UPDATE-

New created lists in SP 2010 work perfectly. Converted lists from SP 2007 (after migration) do not work ... any ideas ..


Same here ... same situation - Office 2010 - Sharepoint 2010 ... we don't have any minus signs in the urls of sharepoint and not in the filename of the attachments ...

:(

 

Apr 1, 2011 at 4:40 PM

Greetings!  This looks like a wonderful tool--exactly what I was looking for!  However, I am having an issue when trying to upload files.  When I do so, the email upload screen displays a message that "An error occurred while uploading. Please check the log."

The log displays the following information:

4/1/2011 10:56 AM  DestinationUrl:http://sharepointserver:81/TES/Client Library/testdoc.pdf
ErrorCode:Unknown
ErrorMessage:Object reference not set to an instance of an object.

I am using Outlook 2010 and Windows Sharepoint Services 3.0.

Any ideas?

 

Thanks!

Jared

Coordinator
Apr 13, 2011 at 11:56 PM

I have just released a new alpha version. There are lots of changes. If you would like to try here is the location;

Here is the alpha version http://spoutlookconnector.codeplex.com/releases/view/64405